Summary
Some 36M and 72M modules shipped after June 2022 may have power present at the external power posts when the unit is off. This article outlines the cause, affected units, and the product correction process.
Affected Models
- 36M and 72M modules
- Shipped after June 2022
Issue
When the module is powered off, voltage may still be present at the external power input posts. While this does not affect firing functionality, it presents a potential safety risk if igniters accidentally touch the external power posts.
Cause
A substitute diode (D5 position) used during production fails under high heat conditions. When it fails, power can remain on at the external posts even when the unit is turned off.
Product Correction Overview
Phase 1: Protective Caps
- Custom caps prevent contact with exposed post metal
- All new 36M and 72M modules shipping now include the protective caps pre-installed
- If your module is affected, the caps will be included as part of your Phase 2 shipment (no separate request needed)
- These caps will also be included on 18M LiPo models moving forward
- Note: Even after the underlying issue is corrected in production, COBRA will continue including these caps to help prevent debris and corrosion at the banana plug receptacle
Phase 2: Internal Adapter Fix (ETA: Summer 2025)
- Hardware adapter prevents voltage from reaching the power posts
- Installs easily with a screwdriver (no soldering or advanced tools required)
- If your module was affected, an email has already been sent with instructions to receive this product correction (includes both the adapter and protective caps)
Future Production
- All future 36M and 72M modules will include a permanent board-level fix to fully eliminate the issue
- This will replace the need for an adapter in new production units
Was I Affected?
If your module is in the affected range, you should have already received an email from us with details on how to receive the product correction items at no cost.
If you didn’t receive an email and believe your module may be affected, please contact help@cobrafiringsystems.com, and we’ll be happy to confirm.
If you're identifying which of your modules are affected based on the serial number, the number is located on a sticker directly on the module enclosure.
If your module is housed inside an armored case, you'll need to loosen the thumb screws on the Pro-Adapt plate and carefully remove the module from the case to view the sticker. Please see How-to remove Pro-Adapt plate from your COBRA 36M or 72M Module for additional instructions.
Request the Correction
Click the link below to confirm your address and request a free product correction kit. Once confirmed, you'll receive the necessary components at no cost. Please submit a request using the Product Correction Part Request form.
Temporary Best Practices
- Avoid touching igniters to the external power posts
Comments
Article is closed for comments.