Do I need a specific firmware version on my 18R2 to use the Command Center?

Yes. For base functionality of the COBRA Command Center including Control Panel and the COBRA Dead Man firmware 4.0 and higher is required. For more advanced features like the SMPTE integration, firmware 5.1.0 and higher is required.

Was this article helpful?
0 out of 0 found this helpful

Articles in this section

See more
Our Support Team Hours:
We can be reached by phone at 518-741-4300 or email help@cobrafiringsystems.com
Emergency Shoot Site Support
COBRA offers a 24-hour support system for on-site emergencies. If you are on a shoot site and encounter a show-stopping issue, please reach out to us via phone at 929-930-6868.